Een van de voordelen van het hosten van je site bij Savvii is dat we jouw WordPress site up to date kunnen houden door je core en plugin updates uit te voeren. Deze feature is zeer belangrijk, omdat het de veiligheid van je site aanzienlijk bevordert. Sites met outdated plugins is een makkelijker doelwit voor aanvallers dan een site die geheel up to date is. Daarom raden wij bij Savvii je altijd aan om je core en plugins door ons te laten updaten. 


Automatische updates inschakelen


De automatische updates kun je aanzetten in onze admin portaal via admin.savvii.com. Kies voor de betreffende site op de knop Beheren > Overzicht. Daar kun je vervolgens los van elkaar de core- en plugin-updates aanzetten met behulp van de knoppen die je hieronder ziet:



Werkwijze automatische updates


We controleren automatisch elke ochtend iedere site waar de knop hierboven omgezet is op beschikbare updates. Voordat we de updates uitvoeren, controleren we eerste op de HTTP statuscode 200 en maken we eerst een back-up van je site. Pas als er een goede back-up is gemaakt, gaan we de beschikbare updates uitvoeren. Door jaren ervaring met het automatisch updaten van plugins op ons platform, weten we dat dit bijna altijd goed gaat. Maar voor de enkele gevallen dat de site crashed controleren we ook na het updaten opnieuw op de HTTP statuscode dat de site teruggeeft. Als dit voorkomt wordt meteen de zojuist gemaakte back-up teruggezet en de klant op de hoogte gebracht. 
  
Het updaten van de WordPress-core gebeurt niet zodra de update uitgebracht wordt. Hiermee wachten we enkele weken, zodat eventuele bugs uitgefilterd kunnen worden.  

Wordt echt alles geüpdatet?


We proberen zo veel mogelijk plugins te updaten. Als het om een of andere reden niet lukt om een plugin te updaten, proberen we dit nog tot twee keer toe, voordat we de plugin op een 'plugin-update-blacklist' zetten specifiek voor die ene site. Deze lijst is terug te vinden in de /log map via sFTP of ssh. Er zijn verschillende reden waarom een plugin op deze lijst terecht kan komen: 
  • Authenticatieproblemen: Sommige plugins vereisen een API-key of inlog voor het ophalen van bestanden om de update mogelijk te maken. Wij hebben vaak geen toegang tot deze credentials. 
  • PHP fouten in je site: Er kunnen ook andere redenen zijn dat een update niet kan worden uitgevoerd. Het kan namelijk ook zijn dat er een fout dieper op applicatieniveau ligt. Dit vereist aandacht van de developer van je website. We zullen het altijd aan je melden welke fout we specifiek tegenkomen. 
  • Speciale mappenstructuur.  

Zie onderstaande list van plugins die niet door ons geüpdatet kunnen worden. (Let op! deze lijst is niet per definitie volledig, het is mogelijk dat er nog meer plugins zijn die door bovengenoemde redenen niet door ons geüpdatet kunnen worden).

astra-addon
bb-theme-builder
eventON, Layerslider
admin-menu-editor-pro
advanced-custom-fields-pro
buddypress,cross-linker
ds-live-composer
fresh-framework
image-cleanup
js_composer
js_composer_theme
memberpress
woocommerce-remove-quantity-fields
uncode-js_composer
wp-migrate-db-pro
wp-migrate-db-pro-media-files
genesis-featured-content-widget
yikes-inc-easy-mailchimp-extender
force-https-littlebizzy
mpc-massive
LayerSlider
revslider
Ultimate_VC_Addons
bb-ultimate-addon